Back to overview
Resolved

API Instability

Jun 24, 2026 at 9:06am UTC
Affected services
Cloudshelves
Manager
Ingest API

Resolved
Jun 24, 2026 at 10:56am UTC

The issue has now been resolved.

We identified that the affected services had picked up Node.js 24.17.0 via a floating Docker image tag, which exposed a known upstream Node.js HTTP keep-alive regression. We have temporarily pinned the affected services to Node.js 24.16.0, which has restored normal operation.

This is a temporary mitigation. We will upgrade to Node.js 24.18.0 or newer as soon as the official Docker image is available, as that release contains the upstream fix while preserving the relevant security updates.

We'll continue monitoring, but service behaviour has returned to normal.

Updated
Jun 24, 2026 at 10:05am UTC

Our team is rolling out a fix now. We will continue to monitor the situation and update you as soon as possible.

Created
Jun 24, 2026 at 9:06am UTC

Our API is currently proving to be unstable due to the latest security patches in an upstream package. We are actively working on a fix and we will roll it out as soon as possible.